UK driving licences increased processing time
Incident Report for Onfido
Resolved
The incident has been resolved
Posted Sep 05, 2019 - 05:34 UTC
Update
We continue to investigate the root causes of this incident.
Posted Sep 05, 2019 - 04:51 UTC
Update
We are continuing to investigate this issue.
Posted Sep 05, 2019 - 04:03 UTC
Investigating
We are currently investigating this issue.
Posted Sep 05, 2019 - 03:30 UTC