Delays in check processing in USA region (us.onfido.com)
Incident Report for Onfido
Resolved
The issue has been resolved and checks are being processed normally.
Posted Jul 31, 2020 - 01:59 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 31, 2020 - 01:59 UTC
Monitoring
We have found and resolved the root cause and are currently monitoring.
Posted Jul 31, 2020 - 01:48 UTC
Investigating
We are currently investigating check processing delays on US.
Posted Jul 31, 2020 - 01:09 UTC