Increased latency on check processing
Incident Report for Onfido
Resolved
The AWS infrastructure services issue is now resolved and so check processing as now returned to normal levels.

We take a lot of pride in running a robust, reliable service and we're working hard to make sure this does not happen again.
Posted Dec 08, 2021 - 03:15 UTC
Update
AWS infrastructure services are improving.

Check processing has resumed and are returning to normal levels.
Posted Dec 08, 2021 - 01:00 UTC
Update
AWS infrastructure issues in the US region remain ongoing. Due to the persistent impact of these issues, Check processing for our Clients hosted in the US region is currently unavailable.

We continue to monitor the situation in conjunction with AWS Support and will provide an update as soon as we have further information.
Posted Dec 07, 2021 - 22:46 UTC
Update
We are monitoring the return to normal processing.

We'll make an update as soon as we see things going back to normal processing.
Posted Dec 07, 2021 - 21:58 UTC
Update
We are monitoring the return to normal processing.

We'll make an update as soon as we see things going back to normal processing.
Posted Dec 07, 2021 - 19:31 UTC
Update
We are seeing evidence that the AWS infrastructure issues in the US region have started to subside.

We are monitoring the return to normal processing.

We will provide an update at 19:30 UTC.
Posted Dec 07, 2021 - 18:50 UTC
Monitoring
We are seeing evidence that the AWS infrastructure issues in the US region have started to subside.

We are monitoring the return to normal processing.

We will provide an update at 18:45 UTC.
Posted Dec 07, 2021 - 18:28 UTC
Identified
We are continuing to experience partial outage in the US region due to AWS infrastructure issues.

Next update will be provided at 18:30 UTC
Posted Dec 07, 2021 - 17:28 UTC
Investigating
We are continuing to experience partial outage in the US region due to AWS infrastructure issues.

Next update will be provided at 17:30 UTC
Posted Dec 07, 2021 - 16:46 UTC
Identified
The issue has been identified and it's related to an AWS partial outage on the US region.

This is only affecting clients on our US region.

We will provide a further update at 16:45 UTC
Posted Dec 07, 2021 - 16:19 UTC
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 16:00 UTC
Update
We're currently experiencing elevated error rates, impacting our US region (*.us.onfido.com), across all our products.

Initial investigations have identified upstream issues in AWS infrastructure.

We will provide an update at 16:15 UTC.
Posted Dec 07, 2021 - 15:58 UTC
Investigating
We've currently experiencing issues that are negatively impacting latency on check processing

Investigation is ongoing and we will update at 16:10 UTC
Posted Dec 07, 2021 - 15:53 UTC
This incident affected: USA (us.onfido.com) (API, Document Verification, Facial Similarity).