Degraded check processing performance
Incident Report for Onfido
Resolved
Network latency fluctuation is back to normal. Check processing performance restored.
Posted Feb 12, 2021 - 18:33 UTC
Investigating
We are currently investigating network latency issues affecting some of our services. Check processing performance may be degraded.
We will post a new update on 19:00 GMT.
Posted Feb 12, 2021 - 17:56 UTC