Watchlist KYC Fallback
Incident Report for Onfido
Resolved
Onfido's data partner for Watchlist KYC (not full) is now operational again.

All Watchlist KYC checks that were pending have been re-run and should now be completed.
Posted Feb 18, 2021 - 00:51 UTC
Monitoring
Fallback is performing correctly and we're continuing to monitor the performance.
Posted Feb 17, 2021 - 21:37 UTC
Investigating
Onfido's data partner for Watchlist KYC (not full) is experiencing issues starting on 17/02/2021 9.20pm UTC.

Some of Onfido’s Watchlist KYC checks may not complete and may remain in the 'pending' status. The fallback provider has been enabled for those clients that approved it. As soon as possible, Onfido will re-run any checks that are pending.

You can keep up to date with the status of our platform at any time by subscribing to status.onfido.com. If you have any questions, feel free to get in touch with us at client-support@onfido.com. We apologise for any inconvenience this may cause.
Posted Feb 17, 2021 - 21:32 UTC