Studio results page latency

Incident Report for Onfido

Resolved

This incident has been resolved.
Posted May 19, 2025 - 15:26 UTC

Monitoring

A fix has been deployed and we're monitoring the result.
Posted May 19, 2025 - 14:21 UTC

Identified

The issue has been identified, we expect to have it resolved in the following minutes for live workflow runs.
Posted May 19, 2025 - 14:15 UTC

Investigating

We've identified an issue that is causing an increase in studio results page latency.
Workflow runs execution are not being affected by this incident, only results page.
Posted May 19, 2025 - 14:12 UTC
This incident affected: Europe (onfido.com) (Dashboard) and Canada (ca.onfido.com) (Dashboard).