Deteriorate performance for Watchlist product
Incident Report for Onfido
Resolved
Impacted checks are now completed.
Performance is now back to normal
Posted Sep 03, 2024 - 14:48 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 03, 2024 - 14:47 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 03, 2024 - 14:45 UTC
Monitoring
The 3rd party provider issue is now resolved.
Watchlist performance is now back to normal.
Any impacted checks will be re-run shortly
Posted Sep 03, 2024 - 14:44 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 03, 2024 - 14:42 UTC
Identified
The issue has been identified on 3rd party provider
Posted Sep 03, 2024 - 14:42 UTC
Update
We are continuing to investigate this issue.
Posted Sep 03, 2024 - 14:42 UTC
Investigating
We are currently investigating the issue
Posted Sep 03, 2024 - 14:27 UTC
This incident affected: USA (us.onfido.com) (Watchlist) and Europe (onfido.com) (Watchlist).