Elevated error rate affecting Autofill in EU region
Incident Report for Onfido
Postmortem

Summary

On Thursday 23 March at 15:05 UTC we have experienced increased error rate on Autofill endpoint in EU region. This was due to an infrastructure change inadvertently released. At 15:32 UTC we have released a fix and the system was back to normal.

Root Causes

An infrastructure change was inadvertently released before necessary application code changes were updated.
This caused an increase in error rate for the Autofill endpoint in EU region.

Timeline

15:05 UTC: The infrastructure change was released
15:10 UTC: We were alerted to the increased error rate on Autofill endpoint
15:18 UTC: We identified the issue and started to release the fix
13:32 UTC: We finished to release the fix and the system went back to normal

Remedies

We’re reviewing our release process for changes involving both infrastructure and code to mitigate human errors. We will ensure necessary control is put to avoid a similar situation in the future.

Posted Mar 24, 2023 - 16:50 UTC

Resolved
We have experienced elevated error rates impacting Autofill between 15:05 and 15:30 GMT, affecting all clients.

We have identified the issue and released a fix immediately.

All systems are back to normal
Posted Mar 23, 2023 - 15:00 UTC