Identity Enhanced degraded performance
Incident Report for Onfido
Resolved
Performance is now back to normal
Posted Sep 18, 2024 - 15:04 UTC
Monitoring
The 3rd party provider issue is now resolved. We are continuing to monitor for any further issues.
Posted Sep 18, 2024 - 14:51 UTC
Identified
Identity Enhanced is experiencing a major decrease in clear rates for applicants all other the world except UK
Posted Sep 18, 2024 - 13:54 UTC
This incident affected: USA (us.onfido.com) (Identity Enhanced) and Europe (onfido.com) (Identity Enhanced).