QES increased turnaround time

Incident Report for Onfido

Resolved

The incident has been resolved. All impacted requests during the period of instability were processed through our retry mechanism.
Posted Sep 27, 2025 - 11:17 UTC

Monitoring

Our provider recovered and the turnaround times are back to normal values.
Posted Sep 27, 2025 - 10:53 UTC

Update

We are still facing elevated error rates with our provider but TaT has improved and the issue continues be to monitored
Posted Sep 27, 2025 - 10:44 UTC

Identified

We are facing a partial outage with our provider which leads to increased turnaround time QES tasks
Posted Sep 27, 2025 - 07:45 UTC
This incident affected: Europe (onfido.com) (QES).