QES tasks cannot complete because our provider is encountering issues.

Incident Report for Onfido

Resolved

The service is operational, no error where detected after the fix.
Posted May 09, 2026 - 12:03 UTC

Monitoring

Our provider fixed the issue. QES tasks are completing now.
Tasks started during the incident were resumed.
Posted May 09, 2026 - 11:32 UTC

Update

The provider is working on a fix.
Posted May 09, 2026 - 11:27 UTC

Identified

We cannot complete QES tasks because our electronic signature provider is encountering issues.
Posted May 09, 2026 - 11:27 UTC
This incident affected: Europe (onfido.com) (QES).