The ID Record product is experiencing errors
Incident Report for Onfido
Resolved
This incident has been resolved.
Posted May 28, 2023 - 00:20 UTC
Investigating
We are currently investigating this issue.
Posted May 27, 2023 - 23:42 UTC
This incident affected: Europe (onfido.com) (Identity Enhanced).