Degraded performance for Identity Reports in UK jurisdiction

Incident Report for Onfido

Resolved

All reports are back to normal.
Posted May 12, 2026 - 13:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results. All clear rates should be back to normal
Posted May 12, 2026 - 12:55 UTC

Identified

We are facing issues with one of our providers and we see a slight decrease in clear rate for Identity Reports in UK jurisdiction
Posted May 11, 2026 - 23:11 UTC
This incident affected: Europe (onfido.com) (Identity Enhanced).