ID Records product is experiencing about 10% decrease in clear rates for applicants in the UK
Incident Report for Onfido
Resolved
This incident has been resolved. We apologize for any inconvenience this has caused.
Posted Oct 05, 2023 - 08:49 UTC
Monitoring
The issue has been resolved. We'll keep on monitoring to ensure that incident is solved.
Posted Oct 05, 2023 - 07:52 UTC
Investigating
ID Record is experiencing about 10% decrease in clear rates for KYC reports in the UK. We are currently investigating and we'll be back with an update shortly.
Posted Oct 05, 2023 - 06:54 UTC
This incident affected: Europe (onfido.com) (Identity Enhanced).