QES performance is affected in EU

Incident Report for Onfido

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 12:28 UTC

Update

The OTP provider is currently facing ongoing performance issues, which are significantly impacting QES workflows.
Posted Oct 20, 2025 - 11:57 UTC

Monitoring

The OTP provider is currently impacted by an AWS outage, resulting in errors within QES workflows.
Posted Oct 20, 2025 - 09:58 UTC

Identified

The OTP provider is currently impacted by an AWS outage, resulting in errors within QES workflows.
Posted Oct 20, 2025 - 09:57 UTC
This incident affected: Europe (onfido.com) (QES).