Increased Turnaround Time
Incident Report for Onfido
Resolved
This issue has now been resolved. We apologize for any inconvenience this has caused.
Posted Dec 05, 2021 - 04:32 UTC
Monitoring
The fix for the Document Checks delays has worked and overall delays are decreasing. We will update you once delays have completely subsided.
Posted Dec 05, 2021 - 04:06 UTC
Investigating
We're investigating reports of delays in completing Document Checks. We are working hard to make sure that completion times return to normal.
Posted Dec 05, 2021 - 01:45 UTC
This incident affected: USA (us.onfido.com) (Document Verification).