Increased check processing latency in Canada
Incident Report for Onfido
Resolved
This incident has been resolved.
Posted Dec 16, 2024 - 18:02 UTC
Update
This incident is resolved. All queued reports have been cleared.

We apologize for the degraded service.
Posted Dec 16, 2024 - 18:00 UTC
Monitoring
The underlying problem has been identified and fixed. New reports are being processed as normal, and we are beginning to handle reports that were impacted and queued.
Posted Dec 16, 2024 - 17:29 UTC
Update
The latency increase is contained to reports going through manual processing from our analysts.
We are continuing to investigate the issue.
Posted Dec 16, 2024 - 15:58 UTC
Investigating
We are facing an issue in our Canada instance where processing latency is increasing.
We are investigating.
Posted Dec 16, 2024 - 15:39 UTC
This incident affected: Canada (ca.onfido.com) (Document Verification).