Degraded performance of QES and Evidence File products

Incident Report for Onfido

Resolved

The incident was resolved
Posted Dec 18, 2025 - 12:31 UTC

Update

Performance of the Evidence File service has been fully restored. However, the Qualified Electronic Signature (QES) service continues to experience significant degradation due to ongoing issues on the QTSP provider’s side.

We are actively monitoring the situation and will share further updates as soon as possible.
Posted Dec 18, 2025 - 11:49 UTC

Monitoring

Our QTSP provider is currently experiencing technical issues that are impacting the performance of our Qualified Electronic Signature (QES) and Evidence File services.
We are actively monitoring the situation and will provide updates as soon as more information becomes available.
Posted Dec 18, 2025 - 11:26 UTC
This incident affected: Europe (onfido.com) (QES).