Increased error rates and latency on US region
Incident Report for Onfido
Resolved
AWS confirms issue is resolved.
Posted Jul 31, 2024 - 05:01 UTC
Monitoring
We are still monitoring the situation, even though AWS does not report full recovery, we don't see errors on our side.
Posted Jul 31, 2024 - 04:47 UTC
Update
We are still monitoring the situation, we are seeing low error rates. We will post when we have further updates.
Posted Jul 31, 2024 - 02:09 UTC
Update
We are still monitoring the situation, we are seeing lower error rates and latencies through all services.
Posted Jul 31, 2024 - 01:39 UTC
Update
We are still monitoring the situation, AWS reports they expect the issue to be resolved in 2-3 hours.
Posted Jul 31, 2024 - 01:09 UTC
Update
We are monitoring the situation and we are in contact with AWS to get the latest details. They are still working on a fix.
Posted Jul 31, 2024 - 00:40 UTC
Identified
We're currently experiencing elevated error rates and latency, impacting our US region, across all our products.
Initial investigations have identified upstream issues in us-east-1 AWS infrastructure.
We are currently in contact with AWS, AWS has identified the problem and they are actively working on a fix.
Posted Jul 31, 2024 - 00:09 UTC
This incident affected: USA (us.onfido.com) (API, Dashboard, Document Verification, Facial Similarity, Watchlist, Identity Enhanced, Webhooks, Known faces, Autofill).