High flagging rate for Document Video Reports

Incident Report for Onfido

Resolved

This issue is now resolved:

We take a lot of pride in running a robust, reliable service and we're working hard to make sure this does not happen again. A detailed postmortem will follow once we've concluded our investigation.
Posted Nov 14, 2025 - 14:10 UTC

Monitoring

The issue has been fixed for new checks going forward. We are still working on assessing the impact for the completed checks.

We will provide a further update in 30 minutes.
Posted Nov 14, 2025 - 13:48 UTC

Identified

The issue has been identified and a fix is being rolled out.

We will provide a further update in 30 minutes.
Posted Nov 14, 2025 - 13:22 UTC
This incident affected: USA (us.onfido.com) (Document Verification), Canada (ca.onfido.com) (Document Verification), and Europe (onfido.com) (Document Verification).