QES/OTP performance is degraded

Incident Report for Onfido

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 20:22 UTC

Identified

We are experiencing degraded performance with QES and OTP services due to an ongoing issue involving AWS and our OTP provider. Our teams are actively working to resolve the situation and restore optimal functionality as soon as possible.
Posted Oct 20, 2025 - 14:48 UTC
This incident affected: Europe (onfido.com) (QES).