Classic dashboard results latency

Incident Report for Onfido

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 19:34 UTC

Monitoring

A fix has been implemented. The team is now monitoring the performance and ensuring the correct propagation of all check results.
Posted Sep 13, 2025 - 19:00 UTC

Investigating

We've identified latency updating classic dashboard results around 18:00 UTC.
Posted Sep 13, 2025 - 18:57 UTC
This incident affected: USA (us.onfido.com) (Dashboard).