Identity Enhanced is experiencing a major decrease in clear rates

Incident Report for Onfido

Resolved

This incident has been resolved.
Posted Jun 29, 2025 - 03:22 UTC

Monitoring

The situation is back to normal, we're monitoring that it's stable.
Posted Jun 29, 2025 - 03:02 UTC

Identified

We're experiencing an issue with one our of provider, resulting in a decrease of clear rates for Identity Enhanced products.
Posted Jun 29, 2025 - 02:09 UTC
This incident affected: USA (us.onfido.com) (Identity Enhanced) and Europe (onfido.com) (Identity Enhanced).