QES tasks outage

Incident Report for Onfido

Resolved

QES is operational again.
Posted May 05, 2026 - 08:39 UTC

Monitoring

The issue has been fixed. We're monitoring and resuming blocked QES tasks, if they can be.
Posted May 05, 2026 - 08:04 UTC

Update

Our provider is fixing the issue. QES tasks still cannot complete.
Posted May 05, 2026 - 07:35 UTC

Identified

Our provider is experiencing issues. All QES tasks cannot complete for now.
Posted May 05, 2026 - 06:56 UTC

Investigating

We noticed an issue with our QES tasks, we're investigating.
Posted May 05, 2026 - 06:52 UTC
This incident affected: Europe (onfido.com) (QES).