Identity Enhanced is experiencing a major decrease in clear rates for applicants all other the world except UK
Incident Report for Onfido
Resolved
The issue has been resolved by our external provider and Identity Record service is now back to normal.
Posted Sep 11, 2023 - 15:21 UTC
Monitoring
The degradation has stopped since 14:49 UTC. We will monitor if the issue is fully resolved.
Posted Sep 11, 2023 - 15:13 UTC
Identified
The underlying provider has found the issue and is working on a fix.
Posted Sep 11, 2023 - 15:07 UTC
Update
We are still investigating issues with one of the providers for identity enhanced.
Posted Sep 11, 2023 - 14:16 UTC
Investigating
We are currently investigating the issue in one of the providers
Posted Sep 11, 2023 - 13:56 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 11, 2023 - 13:55 UTC
This incident affected: USA (us.onfido.com) (Identity Enhanced) and Europe (onfido.com) (Identity Enhanced).