Document checks increased processing time
Incident Report for Onfido
Resolved
This incident has been resolved. Processing time for Document Checks is back to normal values.
Posted Sep 09, 2019 - 13:01 UTC
Investigating
We currently investigating an increased processing time on Document checks.
Posted Sep 09, 2019 - 12:51 UTC