Delays in check processing
Incident Report for Onfido
Resolved
All checks are being completed within the expected values. We apologize for any inconvenience this has caused.
Posted Oct 01, 2020 - 19:46 BST
Monitoring
Starting at 16:30 UTC we experience some delays in completing checks. The issue is now solved and overall delays are decreasing. We will update you once delays have completely subsided
Posted Oct 01, 2020 - 18:19 BST
This incident affected: USA (us.onfido.com) (Check Processing) and Europe (onfido.com) (Check Processing).