Dashboard check latency (US region)

Incident Report for Onfido

Resolved

Incident resolved
Posted May 18, 2025 - 18:44 UTC

Monitoring

A fix was implemented, we're monitoring the result
Posted May 18, 2025 - 18:16 UTC

Identified

We observed some latency on displaying check update in dashboard. Customers may experience check display delay in the dashboard. We're currently working on the fix
Posted May 18, 2025 - 16:48 UTC
This incident affected: USA (us.onfido.com) (Dashboard).