The incident is resolved. The root cause was an issue with AWS in the US region that impacted many AWS services. We will prepare and publish a post mortem in the coming days.
Posted Oct 20, 2025 - 10:07 UTC
Update
Systems are stable. We continue to monitor.
Posted Oct 20, 2025 - 09:47 UTC
Monitoring
Services have been operational since 9:26 UTC. We are monitoring the recovery.
Posted Oct 20, 2025 - 09:26 UTC
Investigating
Due to an outage with our cloud provider we were not able to receive check creation requests or process checks since shortly after 06:48 UTC. The impact was specific to the US region.
The same issue impacted StatusPage and delayed publishing this notice.
Check processing has since resumed. We are monitoring and assessing the situation.
Posted Oct 20, 2025 - 06:48 UTC
This incident affected: USA (us.onfido.com) (API, Dashboard, Document Verification, Facial Similarity, Watchlist, Identity Enhanced, Webhooks, Known faces, Autofill, Device Intelligence).