Delayed check turn-around-times
Incident Report for Onfido
Resolved
We have cleared the backlog of checks and are monitoring closely to make sure issue has been completely resolved and everything is working as expected.

We appreciate your patience during this incident.
Posted Sep 28, 2021 - 08:16 UTC
Identified
Checks undergoing manual review are currently experiencing delayed turn-around-times. We have already identified the issue and are diligently working to clear the current backlog of checks.
Posted Sep 27, 2021 - 12:20 UTC