Degraded performance on Identity Enhanced reports
Incident Report for Onfido
Resolved
Performance is now back to normal
Posted Sep 17, 2024 - 19:19 UTC
Update
We are continuing to monitor for any further issues.
Posted Sep 17, 2024 - 19:10 UTC
Monitoring
The 3rd party provider issue is now resolved. We are continuing to monitor for any further issues.
Posted Sep 17, 2024 - 19:09 UTC
Identified
Identity Enhanced is experiencing a slight decrease in clear rates for applicants all other the world except UK
Posted Sep 17, 2024 - 18:38 UTC
Investigating
We are currently investigating the issue.
Posted Sep 17, 2024 - 18:18 UTC
This incident affected: USA (us.onfido.com) (Identity Enhanced) and Europe (onfido.com) (Identity Enhanced).