Electronic signature high TaT

Incident Report for Onfido

Resolved

The service is operational again.
Posted Jun 16, 2026 - 23:17 UTC

Update

Our provider is still not able to answer to all requests, resulting in longer-than-usual electronic signature task processing time.
Posted Jun 16, 2026 - 22:52 UTC

Identified

Our electronic signature tasks are taking more time to complete because one of our providers is doing some maintenance.
Posted Jun 16, 2026 - 22:19 UTC
This incident affected: Europe (onfido.com) (QES).