High Processing times for Video Facial Similarity Checks

Incident Report for Onfido

Postmortem

Summary

An increase of Facial Similarity Video Manual tasks backlog resulted in higher processing times for about 21% of that variant’s traffic.

Root Causes

A spike in Biometric Video volumes overwhelmed our BPO resources, lengthening Facial Similarity Video check turnaround times impacting around 20% of variant traffic.

Timeline

01:16 GMT: A significant backlog of tasks was reported.

03:27 GMT: BPO team allocated more analysts to process pending video tasks.

06:33 GMT: Backlog was cleared.

Remedies

Not applicable: the increase in TaT resulted exclusively from an unexpected spike in volume that created a backlog for manual analysts. There were no system issues.

Posted Jan 20, 2026 - 14:21 UTC

Resolved

Video facial similarity tasks are taking longer than expected to complete
Posted Jan 14, 2026 - 01:30 UTC